Step by Step how to's
#3409
Andy wrote:
alex24bog wrote:when press the limit switch ,,,the steeper motor tremble ...no stop,,,arduino p008....nema 17  ...tbs6600  ...printer scp600..thanks
It is supposed to hit the back switch and then slowly come forward until it is released.

Make sure you are testing with a fully built system so everything is triggered properly. When doing it by hand it won't be the exact same as the platen moving like it is supposed to.
You really think that can be the problem of motor trembling? I am also testing this wiring and have the same problem. You know it does not matter if platen or finger pushes limit switch I think. It should just stop, not talking about platen returning to the front when there is short delay while platen unclick limit switch.
#3440
Andy wrote:
alex24bog wrote:when press the limit switch ,,,the steeper motor tremble ...no stop,,,arduino p008....nema 17  ...tbs6600  ...printer scp600..thanks
It is supposed to hit the back switch and then slowly come forward until it is released.

Make sure you are testing with a fully built system so everything is triggered properly. When doing it by hand it won't be the exact same as the platen moving like it is supposed to.
So you are saying that when I push the in button platen goes to the back, pushes limit swith and than release it? And than the platen is ready for print?? Let me understand. So IN button function is done when limit switch is released at the end of system? THANKS
#3442
Yes when you send the platen in it hits the back switch and slowly comes off of it. The coming off of the switch is probably the slow movement you say trembles.

This is why I recommend new builders to do the testing with a complete base instead of just the components triggered by hand because some things won't make sense or you might not simulate exactly the same as it normally operates.
#6305
alex24bog wrote:
Mon Nov 07, 2016 6:34 pm
Image

Image
where do the enable pins go? I'm having a hard time figuring this out.

Pin 7?

"# define motorEnable 7 // Not used yet: Some motor drivers require a HIGH signal to enable. "

I have almost the same set up:

-Epson 1430
-Nema 17
-TB6600
-24V/15A
-Arduino Uno


Is there anything else I'm going to need to get this thing working?
#6307
I don't have the open DTG shield unfortunately so that's why I'm asking if it's Pin 7...


Also, all my dip switches on the TB6600 are set to

1- ON
2- OFF
3- OFF
(microstep 4, 800 pulse)
4- OFF
5- OFF
6- OFF
(current 3.5A, PK current 4)


are these the proper settings?


additionally, what kind of push buttons would be suitable to use in terms of amps?
6amps? 10amps?
Last edited by alphaopendtg on Fri Jan 19, 2018 11:41 am, edited 1 time in total.
#6308
alphaopendtg wrote:
Fri Jan 19, 2018 11:30 am
I don't have the open DTG shield unfortunately so that's why I'm asking if it's Pin 7...


Also, all my dip switches on the TB6600 are set to

1- ON
2- OFF
3- OFF
(microstep 4, 800 pulse)
4- OFF
5- OFF
6- OFF
(current 3.5A, PK current 4)


are these the proper settings?
In the Arduino code look at the header.h file to see the Arduino pin assignments.

That should be correct on the stepping, The current depends on what motor you have and it's rating.