Discuss and collaborate Arduino controlled DIY DTG
By phy1212
Can you use the original Epson PE Sensor instead of the software emulation? Would it interfere with the software? what code do i need to remove :?:

I having trouble figuring out the PE min/ max values for my 1430.. I keep getting paper jam errors.
User avatar
By reptilesink
Yes you could use the original sensor if you wanted but ideally use the software.
I have been having the same problems and tried lots of different settings for the pe timing with no luck at all.
I have now discovered that the print settings were default set as borderless. Once I unchecked borderless printing is worked great apart from there is still a problem if I set paper type as premium gloss. At present I am just printing from paint rather than rip software while I get a few things sorted out.
So I suggest you try again with settings to plain paper with borders and see how you get on.
My previous printer which was friction drive without arduino had the same problems using the original pe sensor. I wish I remembered thay before wasting my time adjusting settings.
phy1212 liked this
By phy1212
Changed the defaults to borders and default paper to A3. now it just kicks the platen out using Acrorip

I am able to print using illustrator or paint but the proportions of the image are way off.

float stepperFactor = 8.53; // For Epson 1430 - shared by randyb123
platenEncoder 130000L //For Epson 1430 - shared by randyb123
maxSteps = 9000;
pemin 6000
pemax 6500
User avatar
By reptilesink
If the image is distorted then you need to adjust the stepper factor.
The tooth size on the belt pulley will effect the image so needs be be manually adjusted.
If it is squashed then increase the ammount.
If stretched lower the ammount.
The best way to perfect it is print out a square of say 100mmx100mm and measure it after printing.

Check the paper size and image position in Acrorip once you have the stepper factor perfected in paint.
By phy1212
It's starting to print now but stops in the midldle of the printing 1" squares using ilustrator aND acrorip. Is the cause if this the pemin pemax values? Or is it the platen encoder value?

Also the prints do not print at the same location every print.

I have the printer setup for a3 paper. 11.7"x16.50" in acrorip. Using 130000l for platen encoder.
You do not have the required permissions to view the files attached to this post.
User avatar
By reptilesink
When it stops printing part way does it eject the print or just stop?
It sounds like the platenencoder needs increasing as the printer thinks it is out of paper so stops printing.
It should finish the print then feed out until it gets to the platenencoder count and then eject at a faster speed to the maxsteps distance.
By phy1212
It does not eject. It stops and gives a paper jam error. I'll try increasing the platen encoder.
By phy1212
It's printing good now in illustrator after changing the stepper factor and platen encoder. Still getting error in Acro/ Partner Rip tho

Thanks reptilesink
User avatar
By reptilesink
In acrorip check the paper size is not too large for the printer and what resolution you are printing in.
I tend to use 1400 x 1400 resolution.