Jump to content

Does anyone have an idea of what the cables do?


Recommended Posts

1 minute ago, johnson4 said:

I assume you checked the fuse, from the photo it looks like the epson is powered from the pass through on the aftermarket power supply. 

Have you verified the voltages coming from that power supply as well?

 

It's just weird the base wouldn't function as well. 

 

Thats kinda the end of my " help" without actually physically looking at it. If both power supplies function correctly, the fuses are fine, then I'd start with the mainboard, I don't see why the base wouldn't function without the printer functioning, but It's possible. 

Yeah, it is weird thank you for your help. I'll start testing the aftermarket supply for voltage. I'll post later on with the results. Maybe the wiring is messed up, as far as the base. Does that run on a 12 V or 24 off the afermarket  switch ?

Link to post
Share on other sites

Depending on where you live, the power going into this power supply should match what comes out of L and N, in AC voltage from your wall. 

 

Then, the rest should match the corresponding readings listed on the power supply in DC voltage. If all of them are the same, and the input is correct, I'd assume to replace it. I have never used an analog meter, but it looks like your maybe getting around 9V out of all of them, which- obviously isn't right. personally, I would document very well the location of all the wires, then disconnect the power supply and bench test it with nothing hooked to it, Or you could just replace it. When a power supply goes, sometimes it takes other electronics with it, especially if its putting out a solid voltage across all the terminals going above/below the attached boards requirements. However, this shouldn't affect the Epson board from functioning if it is indeed receiving the correct voltage, unless a short resides somewhere.

 

Good luck!

Link to post
Share on other sites

Yeah, I already order the power supply, gotta wait till i get it though cause its coming from china. It is an arcade power supply. looked everywhere for it here in the states with no luck. I will be ordering the Led driver as well as it seems like there is no power going to the board . Gotta say that i have learned a lot about the equipment then i ever thought i would. In my mind it was going to be Plug and Play lol. Thanks again for the knowledge.

powerboard.jpg

LedDriver.jpg

Link to post
Share on other sites
10 minutes ago, ycramie13 said:

Yeah, I already order the power supply, gotta wait till i get it though cause its coming from china. It is an arcade power supply. looked everywhere for it here in the states with no luck. I will be ordering the Led driver as well as it seems like there is no power going to the board . Gotta say that i have learned a lot about the equipment then i ever thought i would. In my mind it was going to be Plug and Play lol. Thanks again for the knowledge.

powerboard.jpg

LedDriver.jpg

https://www.ebay.com/itm/Arcade-Switching-Power-Supply-12V-5A-5V-24v-20A-bar-top-game-machine-parts-led/113683254194?hash=item1a780ccbb2:g:vAcAAOSwCA5ch8VJ

 

 

Link to post
Share on other sites

I also ordered the led driver. hopefully these parts will let me make some head way on the lack of power issue.

hopefully these one is the correct one. https://www.ebay.com/itm/High-Power-Supply-3W-10W-20W-30W-50W-100W-Constant-Current-COB-Chip-LED-Driver/122480543106?ssPageName=STRK%3AMEBIDX%3AIT&var=422931940360&_trksid=p2060353.m2749.l2649

I'll post later on the result when i get the parts.

Link to post
Share on other sites
22 minutes ago, ycramie13 said:

Thank you for the link!! I ordered it. I guess i didn't look hard enough. I was looking for the Original and got closed minded..

Hey, as long as it helps that's awesome. If I am good at one thing, It's researching and giving long winded responses. It looks like it should work, that base shouldn't have very heavy power requirements.  

 

I hope you get it figured out.

Link to post
Share on other sites
On 10/14/2020 at 12:00 PM, johnson4 said:

Hey, as long as it helps that's awesome. If I am good at one thing, It's researching and giving long winded responses. It looks like it should work, that base shouldn't have very heavy power requirements.  

 

I hope you get it figured out.

So, got the new parts today, and sad to say that nothing changed. replaced the arcade switch, motherboard and main board. No power to any of the components. I'm a bit stuck due to my minimal knowledge of electronics. However i did inspect the setting switches inside the printer and found them to be burnt out i'm assuming that that would explain the no power going to the base and the Screen. see attachments. Now the big issue will be to find them.

switch3.jpg

switch2.jpg

switch1.jpg

Link to post
Share on other sites
55 minutes ago, ycramie13 said:

So, got the new parts today, and sad to say that nothing changed. replaced the arcade switch, motherboard and main board. No power to any of the components. I'm a bit stuck due to my minimal knowledge of electronics. However i did inspect the setting switches inside the printer and found them to be burnt out i'm assuming that that would explain the no power going to the base and the Screen. see attachments. Now the big issue will be to find them.

switch3.jpg

switch2.jpg

switch1.jpg

That would be a stepper driver, which wouldn't prevent the unit from powering on, given it didn't damage the new equipment being shorted out. 

Link to post
Share on other sites
1 hour ago, johnson4 said:

That would be a stepper driver, which wouldn't prevent the unit from powering on, given it didn't damage the new equipment being shorted out. 

thanks, what would you suggest for me to check next?

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...